<!DOCTYPE html><html lang="en-US"><head> <script src="https://cdn.jsdelivr.net/npm/vue"></script> <script>(function(w, d, s, l, i) {
      w[l] = w[l] || [];
      w[l].push({
        'gtm.start': new Date().getTime(),
        event: 'gtm.js'
      });
      var f = d.getElementsByTagName(s)[0],
        j = d.createElement(s),
        dl = l != 'dataLayer' ? '&l=' + l : '';
      j.async = true;
      j.src =
        'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
      f.parentNode.insertBefore(j, f);
    })(window, document, 'script', 'dataLayer', 'GTM-MHVST7S');</script> <meta charset="UTF-8"><link data-optimized='2' rel='stylesheet' href='https://www.thepostmillennial.com/min/5ba2c.css' /><link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/animate.css/3.7.2/animate.min.css" /><link rel='stylesheet' id='gillion-fonts-css' href='https://fonts.googleapis.com/css?family=Montserrat:100,100italic,200,200italic,300,300italic,regular,italic,500,500italic,600,600italic,700,700italic,800,800italic,900,900italic&#038;subset=latin' type='text/css' media='all' /><script type='text/javascript' src='https://www.thepostmillennial.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script><script data-optimized='1' src='https://www.thepostmillennial.com/min/a345e.js'></script><script src="https://cdnjs.cloudflare.com/ajax/libs/socket.io/2.3.0/socket.io.slim.js"></script><script src="https://cdnjs.cloudflare.com/ajax/libs/moment.js/2.24.0/moment.min.js"></script><script src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@12.2.0/dist/lazyload.min.js"></script><script async src="https://www.googletagservices.com/tag/js/gpt.js"></script><script async src="https://thepostmillennial.com/prebidjs/prebid2.44.5-v14.js"></script><script src="https://thepostmillennial.com/prebidjs/pb_init.js"></script><script src="https://thepostmillennial.com/prebidjs/pb_define.js"></script><script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <meta name="viewport" content="width=device-width, initial-scale=1"><title>BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza</title><meta name="description" content="Jonathan Levine was suspended from Twitter for posting a story about journalist Carlos Maza, twice. He was reinstated only to be banned again." /><link rel="canonical" href="https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza" /><meta property="og:description" content="Jonathan Levine was suspended from Twitter for posting a story about journalist Carlos Maza, twice. He was reinstated only to be banned again." /><meta property="og:url" content="https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/" /><meta property="og:site_name" content="The Post Millennial" /><meta property="article:tag" content="censorship" /><meta property="article:tag" content="journalist" /><meta property="article:tag" content="Social Media" /><meta property="article:tag" content="Twitter" /><meta property="article:section" content="News" /><meta property="article:published_time" content="2020-03-08T20:11:07+00:00" /><meta property="article:modified_time" content="2020-03-08T20:14:43+00:00" /><meta property="og:updated_time" content="2020-03-08T20:14:43+00:00" /><meta property="og:image" content="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg" /><meta property="og:image:secure_url" content="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg" /><meta property="og:image:width" content="1600" /><meta property="og:image:height" content="800" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Jonathan Levine was suspended from Twitter for posting a story about journalist Carlos Maza, twice. He was reinstated only to be banned again." /><meta name="twitter:title" content="BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza" /><meta name="twitter:image" content="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.thepostmillennial.com/#website","url":"https://www.thepostmillennial.com/","name":"The Post Millennial","potentialAction":{"@type":"SearchAction","target":"https://www.thepostmillennial.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/#primaryimage","url":"https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg","width":1600,"height":800},{"@type":"WebPage","@id":"https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/#webpage","url":"https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/","inLanguage":"en-US","name":"BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza","isPartOf":{"@id":"https://www.thepostmillennial.com/#website"},"primaryImageOfPage":{"@id":"https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/#primaryimage"},"datePublished":"2020-03-08T20:11:07+00:00","dateModified":"2020-03-08T20:14:43+00:00","author":{"@id":"https://www.thepostmillennial.com/#/schema/person/9dc858035f06bafcdab9894a6c8f46fc"},"description":"Jonathan Levine was suspended from Twitter for posting a story about journalist Carlos Maza, twice. He was reinstated only to be banned again."},{"@type":["Person"],"@id":"https://www.thepostmillennial.com/#/schema/person/9dc858035f06bafcdab9894a6c8f46fc","name":"Libby Emmons and Roberto Wakerell-Cruz","image":{"@type":"ImageObject","@id":"https://www.thepostmillennial.com/#authorlogo","url":"https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-96x96.jpg","caption":"Libby Emmons and Roberto Wakerell-Cruz"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Post Millennial &raquo; Feed" href="https://www.thepostmillennial.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The Post Millennial &raquo; Comments Feed" href="https://www.thepostmillennial.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Post Millennial &raquo; BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza Comments Feed" href="https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thepostmillennial.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-.1em !important;background:0 0 !important;padding:0 !important}</style><style id='tptn-style-left-thumbs-inline-css' type='text/css'>img.tptn_thumb{width:70px !important;height:70px !important}.tptn_posts_widget2 img.tptn_thumb{width:70px !important;height:70px !important}</style><style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url('https://www.thepostmillennial.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');border:1px solid #c8c8c8}</style><!--[if lt IE 9]><link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.thepostmillennial.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.2' type='text/css' media='screen' />
<![endif]--><style id='gillion-responsive-inline-css' type='text/css'>.mc-modal{left:20px !important}</style> <script type='text/javascript'>/*  */
var gillion_loadmore_posts = {"ajax_url":"https:\/\/www.thepostmillennial.com\/wp-admin\/admin-ajax.php"};
var gillion = {"siteurl":"https:\/\/www.thepostmillennial.com\/","loggedin":"","page_loader":"0","notice":"","header_animation_dropdown_delay":"1000","header_animation_dropdown":"easeOutQuint","header_animation_dropdown_speed":"300","lightbox_opacity":"0.88","lightbox_transition":"elastic","page_numbers_prev":"Previous","page_numbers_next":"Next","rtl_support":"","footer_parallax":"","social_share":"{\"email\":true,\"twitter\":true,\"facebook\":true,\"linkedin\":true}","text_show_all":"Show All"};
/*  */</script> <link rel='https://api.w.org/' href='https://www.thepostmillennial.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thepostmillennial.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thepostmillennial.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.2" /><link rel='shortlink' href='https://www.thepostmillennial.com/?p=119160' /><link rel="alternate" type="application/json+oembed" href="https://www.thepostmillennial.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thepostmillennial.com%2Fbreaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.thepostmillennial.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thepostmillennial.com%2Fbreaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza%2F&#038;format=xml" /> <script type="text/javascript">window.MemberfulOptions = {
    site: "https://thepostmillennial.memberful.com",
    intercept: [
            "http://www.thepostmillennial.com/?memberful_endpoint=auth",
            "https://www.thepostmillennial.com/?memberful_endpoint=auth",
            "http://www.thepostmillennial.com?memberful_endpoint=auth",
            "https://www.thepostmillennial.com?memberful_endpoint=auth",
          ],
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); }

    if(s.addEventListener) {
      s.addEventListener("load", setup, false);
    } else {
      s.attachEvent("onload", setup);
    }

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();</script> <style type="text/css"></style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /><meta name="onesignal" content="wordpress-plugin" /> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.thepostmillennial.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '298afc97-8f45-46ff-8639-bdfb5fc1d55d';
oneSignal_options['autoRegister'] = false;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Breaking News - The Post Millennial";
oneSignal_options['welcomeNotification']['message'] = "Example breaking news message!";
oneSignal_options['path'] = "https://www.thepostmillennial.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4e197e53-7d58-4e85-b8d7-9d182b545f43";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = 'Get breaking news alerts sent to you -  The Post Millennial';
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel="icon" href="https://www.thepostmillennial.com/wp-content/uploads/2019/07/cropped-fvlarge-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.thepostmillennial.com/wp-content/uploads/2019/07/cropped-fvlarge-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://www.thepostmillennial.com/wp-content/uploads/2019/07/cropped-fvlarge-1-180x180.png" /><meta name="msapplication-TileImage" content="https://www.thepostmillennial.com/wp-content/uploads/2019/07/cropped-fvlarge-1-270x270.png" />
<noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body class="post-template-default single single-post postid-119160 single-format-standard singular sh-body-header-sticky sh-bookmarks-style_meta sh-title-style2 sh-section-tabs-style3 sh-carousel-style2 sh-carousel-position-bottom sh-post-categories-style2 sh-review-style2 sh-meta-order-top sh-instagram-widget-columns3 sh-categories-position-image sh-media-icon-style2 sh-wc-labels-off sh-instagram-widget-with-button wpb-js-composer js-comp-ver-6.0.2 vc_responsive">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MHVST7S" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div class="sh-header-side"><div id="widget_tptn_pop-2" class="widget-item tptn_posts_list_widget"><div class="sh-widget-title-styling"><h3 class="widget-title">Trending</h3></div><div class="tptn_posts_daily  tptn_posts_widget tptn_posts_widget2"><ul><li><a href="https://www.thepostmillennial.com/twitter-suspends-ny-post-writer-after-he-exposes-carlos-mazas-riches-and-hypocrisy/" class="tptn_link"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="70" height="70" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-70x70.jpg" class="tptn_thumb tptn_featured" alt="Twitter suspends NY Post writer after he exposes Carlos Maza’s riches and hypocrisy" title="Twitter suspends NY Post writer after he exposes Carlos Maza’s riches and hypocrisy" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-70x70.jpg 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-150x150.jpg 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-24x24.jpg 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-48x48.jpg 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-96x96.jpg 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-300x300.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-585x585.jpg 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-220x220.jpg 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-80x80.jpg 80w" data-sizes="(max-width: 70px) 100vw, 70px" /><noscript><img  width="70" height="70"  src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-70x70.jpg" class="tptn_thumb tptn_featured" alt="Twitter suspends NY Post writer after he exposes Carlos Maza’s riches and hypocrisy" title="Twitter suspends NY Post writer after he exposes Carlos Maza’s riches and hypocrisy" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-70x70.jpg 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-150x150.jpg 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-24x24.jpg 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-48x48.jpg 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-96x96.jpg 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-300x300.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-585x585.jpg 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-220x220.jpg 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-80x80.jpg 80w" sizes="(max-width: 70px) 100vw, 70px" /></noscript></a><span class="tptn_after_thumb"><a href="https://www.thepostmillennial.com/twitter-suspends-ny-post-writer-after-he-exposes-carlos-mazas-riches-and-hypocrisy/" class="tptn_link"><span class="tptn_title">Twitter suspends NY Post writer after he exposes&hellip;</span></a></span></li><li><a href="https://www.thepostmillennial.com/revealed-antifa-has-a-pedophile-problem/" class="tptn_link"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="70" height="70" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-70x70.png" class="tptn_thumb tptn_featured" alt="REVEALED: Antifa has a pedophile problem" title="REVEALED: Antifa has a pedophile problem" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-585x585.png 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-80x80.png 80w" data-sizes="(max-width: 70px) 100vw, 70px" /><noscript><img  width="70" height="70"  src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-70x70.png" class="tptn_thumb tptn_featured" alt="REVEALED: Antifa has a pedophile problem" title="REVEALED: Antifa has a pedophile problem" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-585x585.png 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-25-80x80.png 80w" sizes="(max-width: 70px) 100vw, 70px" /></noscript></a><span class="tptn_after_thumb"><a href="https://www.thepostmillennial.com/revealed-antifa-has-a-pedophile-problem/" class="tptn_link"><span class="tptn_title">REVEALED: Antifa has a pedophile problem</span></a></span></li><li><a href="https://www.thepostmillennial.com/manitoba-rejects-handgun-ban-wont-make-any-difference-whatsoever/" class="tptn_link"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="70" height="70" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-70x70.png" class="tptn_thumb tptn_featured" alt="Manitoba REJECTS handgun ban: &#039;Won&#039;t make any difference whatsoever&#039;" title="Manitoba REJECTS handgun ban: &#039;Won&#039;t make any difference whatsoever&#039;" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-585x585.png 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-80x80.png 80w" data-sizes="(max-width: 70px) 100vw, 70px" /><noscript><img  width="70" height="70"  src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-70x70.png" class="tptn_thumb tptn_featured" alt="Manitoba REJECTS handgun ban: &#039;Won&#039;t make any difference whatsoever&#039;" title="Manitoba REJECTS handgun ban: &#039;Won&#039;t make any difference whatsoever&#039;" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-585x585.png 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-74-80x80.png 80w" sizes="(max-width: 70px) 100vw, 70px" /></noscript></a><span class="tptn_after_thumb"><a href="https://www.thepostmillennial.com/manitoba-rejects-handgun-ban-wont-make-any-difference-whatsoever/" class="tptn_link"><span class="tptn_title">Manitoba REJECTS handgun ban: &#8216;Won&#8217;t&hellip;</span></a></span></li><li><a href="https://www.thepostmillennial.com/rcmp-will-not-investigate-railway-derailments-report-finds/" class="tptn_link"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="70" height="70" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-70x70.png" class="tptn_thumb tptn_featured" alt="RCMP will not investigate railway derailments, report finds" title="RCMP will not investigate railway derailments, report finds" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-80x80.png 80w" data-sizes="(max-width: 70px) 100vw, 70px" /><noscript><img  width="70" height="70"  src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-70x70.png" class="tptn_thumb tptn_featured" alt="RCMP will not investigate railway derailments, report finds" title="RCMP will not investigate railway derailments, report finds" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/postt-80x80.png 80w" sizes="(max-width: 70px) 100vw, 70px" /></noscript></a><span class="tptn_after_thumb"><a href="https://www.thepostmillennial.com/rcmp-will-not-investigate-railway-derailments-report-finds/" class="tptn_link"><span class="tptn_title">RCMP will not investigate railway derailments, report finds</span></a></span></li><li><a href="https://www.thepostmillennial.com/omar-khadrs-lawyer-given-judicial-appointment-by-trudeau-government/" class="tptn_link"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="70" height="70" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-70x70.png" class="tptn_thumb tptn_featured" alt="Omar Khadr&#039;s lawyer appointed judge by the Trudeau government in Alberta" title="Omar Khadr&#039;s lawyer appointed judge by the Trudeau government in Alberta" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-585x585.png 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-80x80.png 80w" data-sizes="(max-width: 70px) 100vw, 70px" /><noscript><img  width="70" height="70"  src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-70x70.png" class="tptn_thumb tptn_featured" alt="Omar Khadr&#039;s lawyer appointed judge by the Trudeau government in Alberta" title="Omar Khadr&#039;s lawyer appointed judge by the Trudeau government in Alberta" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-70x70.png 70w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-150x150.png 150w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-24x24.png 24w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-48x48.png 48w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-96x96.png 96w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-300x300.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-585x585.png 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-220x220.png 220w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Untitled-design-79-80x80.png 80w" sizes="(max-width: 70px) 100vw, 70px" /></noscript></a><span class="tptn_after_thumb"><a href="https://www.thepostmillennial.com/omar-khadrs-lawyer-given-judicial-appointment-by-trudeau-government/" class="tptn_link"><span class="tptn_title">Omar Khadr&#8217;s lawyer appointed judge by the&hellip;</span></a></span></li></ul><div class="tptn_clear"></div></div></div></div><div class="sh-header-side-overlay"></div><div id="page-container" class=""><header class="primary-mobile"><div id="header-mobile" class="sh-header-mobile"><div class="sh-header-mobile-navigation"><div class="container"><div class="sh-table"><div class="sh-table-cell"><nav id="header-navigation-mobile" class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav"><li><div class="sh-hamburger-menu sh-nav-dropdown">
<span></span>
<span></span>
<span></span>
<span></span></div></li></ul></div></nav></div><div class="sh-table-cell sh-header-logo-container"><div class="header-logo">
<a href="https://www.thepostmillennial.com/" class="header-logo-container sh-table-small"><div class="sh-table-cell"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" class="sh-standard-logo" data-src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /><noscript><img class="sh-standard-logo" src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /></noscript>
<img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" class="sh-sticky-logo" data-src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /><noscript><img class="sh-sticky-logo" src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /></noscript>
<img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" class="sh-light-logo" data-src="//www.thepostmillennial.com/wp-content/uploads/2019/07/favicn.png" alt="The Post Millennial" /><noscript><img class="sh-light-logo" src="//www.thepostmillennial.com/wp-content/uploads/2019/07/favicn.png" alt="The Post Millennial" /></noscript></div>
</a></div></div><div class="sh-table-cell"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav"><li class="menu-item menu-item-has-children sh-nav-readmore sh-nav-special"> <a href="https://www.thepostmillennial.com/?read-it-later"><div> <i class="ti-bookmark"></i> <span class="sh-read-later-total">0</span></div> </a></li></ul></div></nav></div></div></div></div><nav class="sh-header-mobile-dropdown"><div class="container sh-nav-container"><ul class="sh-nav-mobile"></ul></div><div class="container sh-nav-container"><div class="header-mobile-social-media">
<a href="https://www.facebook.com/ThePostMillennial/" target="_blank" class="social-media-facebook">
<i class="fa fa-facebook"></i>
</a><a href="https://twitter.com/TPostMillennial" target="_blank" class="social-media-twitter">
<i class="fa fa-twitter"></i>
</a><a href="https://www.instagram.com/thepostmillennial/" target="_blank" class="social-media-instagram">
<i class="fa fa-instagram"></i>
</a><a href="https://www.youtube.com/channel/UCOzojJATlDfb6LdXCXN79zg" target="_blank" class="social-media-youtube">
<i class="fa fa-youtube"></i>
</a><a href="https://www.linkedin.com/company/18260476/admin/" target="_blank" class="social-media-linkedin">
<i class="fa fa-linkedin"></i>
</a><a href="#login-register" class="sh-login-popup sh-login-popup-trigger">Log in</a><div class="sh-clear"></div></div></div><div class="header-mobile-search"><div class="container sh-nav-container"><form role="search" method="get" class="header-mobile-form" action="https://www.thepostmillennial.com/">
<input class="header-mobile-form-input" type="text" placeholder="Search here.." value="" name="s" required />
<button type="submit" class="header-mobile-form-submit">
<i class="icon-magnifier"></i>
</button></form></div></div></nav></div></header><header class="primary-desktop"><div class="sh-header-top"><div class="container"><div class="sh-table"><div class="sh-table-cell"><div class="sh-nav-container"><ul id="menu-topbar-navigation" class="sh-nav"><li id="menu-item-84145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84145"><a href="https://www.thepostmillennial.com/?memberful_endpoint=auth">Sign in</a></li><li id="menu-item-82525" class="subscribe_link menu-item menu-item-type-custom menu-item-object-custom menu-item-82525"><a href="https://www.thepostmillennial.com/membership/">Try 1 month for FREE</a></li></ul></div></div><div class="sh-table-cell"><div class="sh-header-top-meta"><div class="header-social-media">
<a href="https://www.facebook.com/ThePostMillennial/" target="_blank" class="social-media-facebook">
<i class="fa fa-facebook"></i>
</a><a href="https://twitter.com/TPostMillennial" target="_blank" class="social-media-twitter">
<i class="fa fa-twitter"></i>
</a><a href="https://www.instagram.com/thepostmillennial/" target="_blank" class="social-media-instagram">
<i class="fa fa-instagram"></i>
</a><a href="https://www.youtube.com/channel/UCOzojJATlDfb6LdXCXN79zg" target="_blank" class="social-media-youtube">
<i class="fa fa-youtube"></i>
</a><a href="https://www.linkedin.com/company/18260476/admin/" target="_blank" class="social-media-linkedin">
<i class="fa fa-linkedin"></i>
</a><a href="#login-register" class="sh-login-popup sh-login-popup-trigger">Log in</a><div class="sh-clear"></div></div><div class="sh-header-top-date">
<span class="sh-header-top-date-day">08</span>
<span class="sh-header-top-date-meta">
<span class="sh-header-top-date-month">Mar</span>
<span class="sh-header-top-date-year">2020</span>
</span></div></div></div></div></div></div><div class="sh-header-height sh-header-5 sh-header-4"><div class="sh-header-middle"><div class="container sh-header-additional"><div class="sh-table"><div class="sh-table-cell sh-header-logo-container"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav sh-nav-left"><li><div class="header-logo">
<a href="https://www.thepostmillennial.com/" class="header-logo-container sh-table-small"><div class="sh-table-cell"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" class="sh-standard-logo" data-src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /><noscript><img class="sh-standard-logo" src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /></noscript>
<img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" class="sh-sticky-logo" data-src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /><noscript><img class="sh-sticky-logo" src="//www.thepostmillennial.com/wp-content/uploads/2019/11/logo.png" alt="The Post Millennial" /></noscript>
<img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" class="sh-light-logo" data-src="//www.thepostmillennial.com/wp-content/uploads/2019/07/favicn.png" alt="The Post Millennial" /><noscript><img class="sh-light-logo" src="//www.thepostmillennial.com/wp-content/uploads/2019/07/favicn.png" alt="The Post Millennial" /></noscript></div>
</a></div></li></ul></div></nav></div></div></div></div><div class="sh-header sh-header-4 sh-sticky-header"><div class="container sh-header-standard"><div class="sh-table"><div class="sh-table-cell sh-header-meta1-container"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav"><li class="menu-item sh-nav-search sh-nav-special">
<a href="#"><i class="icon icon-magnifier"></i></a></li><li class="menu-item menu-item-has-children sh-nav-share sh-nav-special">
<a href="#"><div>
<i class="icon icon-share"></i></div>
</a><ul class="sub-menu sh-nav-share-ul"><li class="sh-share-item sh-share-item-facebook menu-item">
<a href="https://www.facebook.com/ThePostMillennial/" target="_blank">
<i class="fa fa-facebook"></i>
</a></li><li class="sh-share-item sh-share-item-twitter menu-item">
<a href="https://twitter.com/TPostMillennial" target="_blank">
<i class="fa fa-twitter"></i>
</a></li><li class="sh-share-item sh-share-item-instagram menu-item">
<a href="https://www.instagram.com/thepostmillennial/" target="_blank">
<i class="fa fa-instagram"></i>
</a></li><li class="sh-share-item sh-share-item-youtube menu-item">
<a href="https://www.youtube.com/channel/UCOzojJATlDfb6LdXCXN79zg" target="_blank">
<i class="fa fa-youtube"></i>
</a></li><li class="sh-share-item sh-share-item-linkedin menu-item">
<a href="https://www.linkedin.com/company/18260476/admin/" target="_blank">
<i class="fa fa-linkedin"></i>
</a></li></ul></li></ul></div></nav></div><div class="sh-table-cell"><nav id="header-navigation" class="header-standard-position"><div class="sh-nav-container"><ul id="menu-header-navigation" class="sh-nav"><li id="menu-item-1268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1268"><a href="https://www.thepostmillennial.com/">Home</a></li><li id="menu-item-82539" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-82539"><a href="https://www.thepostmillennial.com/category/news/">News</a><ul class="sub-menu"><li id="menu-item-82540" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-82540"><a href="https://www.thepostmillennial.com/category/news/america-news/">American News</a></li><li id="menu-item-81730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-81730"><a href="https://www.thepostmillennial.com/category/news/canada-news/">Canadian News</a><ul class="sub-menu"><li id="menu-item-82541" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82541"><a href="https://www.thepostmillennial.com/category/news/canada-news/alberta/">Alberta</a></li><li id="menu-item-82542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82542"><a href="https://www.thepostmillennial.com/category/news/canada-news/british-columbia/">British Columbia</a></li><li id="menu-item-82543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82543"><a href="https://www.thepostmillennial.com/category/news/canada-news/federal/">Federal</a></li><li id="menu-item-82545" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82545"><a href="https://www.thepostmillennial.com/category/news/canada-news/ontario/">Ontario</a></li><li id="menu-item-82544" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82544"><a href="https://www.thepostmillennial.com/category/news/canada-news/manitoba/">Manitoba</a></li><li id="menu-item-82546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82546"><a href="https://www.thepostmillennial.com/category/news/canada-news/quebec/">Quebec</a></li><li id="menu-item-82547" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82547"><a href="https://www.thepostmillennial.com/category/news/canada-news/saskatchewan/">Saskatchewan</a></li></ul></li><li id="menu-item-82548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82548"><a href="https://www.thepostmillennial.com/category/news/international-news/">International News</a></li></ul></li><li id="menu-item-81734" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-81734"><a href="https://www.thepostmillennial.com/category/politics_policy/">Politics</a><ul class="sub-menu"><li id="menu-item-112660" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112660"><a href="https://www.thepostmillennial.com/category/cpc-leadership-race/">CPC Leadership Race</a></li></ul></li><li id="menu-item-83873" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83873"><a href="https://www.thepostmillennial.com/category/culture/">Culture</a></li><li id="menu-item-84099" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84099"><a href="https://www.thepostmillennial.com/category/business_finance/">Business &#038; Finance</a></li><li id="menu-item-82549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82549"><a href="https://www.thepostmillennial.com/category/opinion/">Opinion</a></li></ul></div></nav></div><div class="sh-table-cell sh-header-meta2-container"><nav class="header-standard-position"><div class="sh-nav-container"><ul class="sh-nav"><li class="menu-item sh-nav-menu sh-nav-special">
<a href="#">
<i class="ti-bolt-alt sh-nav-menu-icon-closed" data-attr-closed="ti-bolt-alt" data-attr-opened="ti-close"></i>
</a></li><li class="menu-item menu-item-has-children sh-nav-readmore sh-nav-special"> <a href="https://www.thepostmillennial.com/?read-it-later"><div> <i class="ti-bookmark"></i> <span class="sh-read-later-total">0</span></div> </a><ul class="sub-menu sh-read-later-list sh-read-later-list-init"><li class="sh-read-later-item menu-item text-center"> <a href="https://www.thepostmillennial.com/?read-it-later"> Login to add posts to your read later list </a></li></ul></li></ul></div></nav></div></div></div><div class="sh-header-search-side"><div class="sh-header-search-side-container"><form method="get" class="sh-header-search-form" action="https://www.thepostmillennial.com/">
<input type="text" value="" name="s" class="sh-header-search-side-input" placeholder="Enter a keyword to search..." /><div class="sh-header-search-side-close">
<i class="ti-close"></i></div><div class="sh-header-search-side-icon">
<i class="ti-search"></i></div></form></div></div></div></div></header><div class="sh-titlebar"><div class="container"><div class="sh-table sh-titlebar-height-small"><div class="titlebar-title sh-table-cell"><h2>
Blog Post</h2></div><div class="title-level sh-table-cell"><div id="breadcrumbs" class="breadcrumb-trail breadcrumbs"><span class="item-home"><a class="bread-link bread-home" href="https://www.thepostmillennial.com/" title="Home">Home</a></span><span class="separator"> &gt; </span><span class="item-cat"><a href="https://www.thepostmillennial.com/category/news/">News</a></span><span class="separator"> &gt; </span><span class="item-current item-119160"><span class="bread-current bread-119160" title="BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza">BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza</span></span></div></div></div></div></div><div id="wrapper" class="layout-default"><div class="content-container sh-page-layout-default"><div class="container entry-content"><div id="content-wrapper" class="content-wrapper-with-sidebar"><div id="content" class="content-layout-sidebar-right content-with-sidebar-right"><div class="blog-single blog-style-single blog-style-single-share  blog-blockquote-style2  blog-style-post-standard"><article id="post-119160" class="post-item post-item-single post-119160 post type-post status-publish format-standard has-post-thumbnail hentry category-america-news category-culture category-news tag-censorship tag-journalist tag-social-media tag-twitter"><div class="post-type-content"><div class="post-thumbnail">
<img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-1200x675.jpg" alt="BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza"><noscript><img src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-1200x675.jpg" alt="BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza"></noscript>
<a href="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg" class="post-lightbox" data-rel="lightcase:post_gallery_119160"></a></div></div><div class="post-item-single-container"><div class="post-content-share post-content-share-bar"></div><div class="post-single-meta"><div class="post-categories-container"><div class="post-categories"><a href="https://www.thepostmillennial.com/category/news/america-news/">American News</a></div></div>
<a class="post-title"><h1>
BREAKING: Twitter RE-SUSPENDS NY Post writer for tweets about activist journalist Carlos Maza&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="119160"><i class="fa fa-bookmark-o"></i></span></h1>
</a><div class="post-meta"><div class="post-meta-content">
<span class="post-auhor-date post-auhor-date-full">
<a href="https://www.thepostmillennial.com/author/robolib/">
<img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="28" height="28" data-src="https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-48x48.jpg" class="avatar avatar-28 photo post-author-image" alt="" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-48x48.jpg 48w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-150x150.jpg 150w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-300x300.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-768x768.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-70x70.jpg 70w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-24x24.jpg 24w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-96x96.jpg 96w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-585x585.jpg 585w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-220x220.jpg 220w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-80x80.jpg 80w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1.jpg 960w" data-sizes="(max-width: 28px) 100vw, 28px" /><noscript><img width="28" height="28" src="https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-48x48.jpg" class="avatar avatar-28 photo post-author-image" alt="" srcset="https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-48x48.jpg 48w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-150x150.jpg 150w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-300x300.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-768x768.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-70x70.jpg 70w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-24x24.jpg 24w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-96x96.jpg 96w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-585x585.jpg 585w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-220x220.jpg 220w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1-80x80.jpg 80w, https://www.thepostmillennial.com/wp-content/uploads/2019/08/67532514_2305442053006671_583408282811498496_n-1.jpg 960w" sizes="(max-width: 28px) 100vw, 28px" /></noscript> </a>
<span>
<a href="https://www.thepostmillennial.com/author/robolib/" class="post-author">Libby Emmons and Roberto Wakerell-Cruz</a></span>,
<a href="https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/" class="post-date">
4 mins ago </a>
</span>
<span class="post-readtime">
<i class="icon icon-clock"></i>
1 min <span>read</span> </span>
<span class="desktop-post-read-later">
&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="119160"><i class="fa fa-bookmark-o"></i></span> </span></div></div></div><div class="post-content post-single-content"> <script>console.log( 'Debug Objects: 119160' );</script> <div class="content_restrict_notification animated fadeInUp delay-3s">You have <span style="color:#999;">10</span> free articles left today, enjoy reading.</div><div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568834855780-0"></div></div><p>After Jonathan Levine was suspended from Twitter for posting a story about journalist Carlos Maza, he appealed the decision and was reinstated. In an email, a representative from Twitter claimed that the suspension was &#8220;in error.&#8221; Shortly thereafter, however, Levine received further correspondence from a Twitter spokesperson.</p><figure class="wp-block-image"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-648x1024.jpg" alt="" class="wp-image-119168" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-648x1024.jpg 648w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-190x300.jpg 190w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-768x1214.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-585x925.jpg 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1.jpg 1012w" data-sizes="(max-width: 648px) 100vw, 648px" /><noscript><img src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-648x1024.jpg" alt="" class="wp-image-119168" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-648x1024.jpg 648w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-190x300.jpg 190w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-768x1214.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1-585x925.jpg 585w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/f2f118fb-503f-4e37-9092-cc3567a6920c-1.jpg 1012w" sizes="(max-width: 648px) 100vw, 648px" /></noscript></figure><p></p><div class='code-block code-block-15' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1578941510716-0" style="width: 1px; height: 1px;"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1578941510716-0'); });</script> </div></div><p>Writing for <em>The Post Millennial</em> <a href="https://www.thepostmillennial.com/twitter-suspends-ny-post-writer-after-he-exposes-carlos-mazas-riches-and-hypocrisy/">earlier today</a>, Ian Miles Cheong detailed the account of Jonathan Levine&#8217;s Twitter suspension.</p><p>Levine called the resuspension “Orwellian,” tweeting: “Despite initially calling their decision to lock my account “an error” — Twitter locked me out again a few hours later over the same Carlos Maza story.”</p><div class='code-block code-block-8' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055028523-0"></div></div><p>“I have reluctantly deleted the tweet and I’m sharing with you some of the timeline here,” said Levine.&nbsp;</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">SECOND UPDATE:<br><br>Despite initially calling their decision to lock my account “an error” — Twitter locked me out again a few hours later over the same Carlos Maza story. <br><br>I have reluctantly deleted the tweet and I’m sharing with you some of the timeline here <br><br>The is Orwellian <a href="https://t.co/tZifmpWUg7">https://t.co/tZifmpWUg7</a> <a href="https://t.co/AIqHreCmZW">pic.twitter.com/AIqHreCmZW</a></p>&mdash; Jon Levine (@LevineJonathan) <a href="https://twitter.com/LevineJonathan/status/1236739360910979080?ref_src=twsrc%5Etfw">March 8, 2020</a></blockquote></div></figure><p>The controversy around Levine and Mazda first started when the New York Post published an article titled&nbsp;<a href="https://nypost.com/2020/03/07/youtube-socialist-carlos-maza-slams-the-wealthy-but-lives-in-luxury/">“YouTube socialist Carlos Maza slams the wealthy but lived in luxury,”</a>&nbsp;</p><p>In the article, Levine detailed how the social media activist lives in luxury, all while condemning others for their wealthy.</p><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055085416-0"></div></div><p>Maza attained widespread internet infamy last year when he spearheaded a campaign to deplatform conservative comedian and commentator Steven Crowder from YouTube. Maza continues to call for the suspensions of his political adversaries on social media, professing so much in his Twitter bio which claims that “YouTube profits off of hate speech.”</p><div class='code-block code-block-11' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1568235957261-0"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1568235957261-0'); });</script> </div></div><div class='code-block code-block-16' style='margin: 8px 0; clear: both;'><hr style=" border: 0; height: 1px; background: #333; background-image: linear-gradient(to right, #ccc, #333, #ccc);" /><div id="page-actions" style="line-height: 40px;"><h5>Want to help us grow? Here's what you can do!</h5><ol><li>
<a href="https://www.thepostmillennial.com/membership/" style="font-size:16px;">Become a member</a
></li><li>
<a href="https://www.facebook.com/ThePostMillennial/" style="font-size:16px;">Like our page on Facebook</a
></li><li>
<a href="https://twitter.com/TPostMillennial" style="font-size:16px;">Follow us on Twitter</a
></li></ol></div></div></div><div class="sh-page-links"></div><div class="post-tags-container"><div class="post-tags">
<a class="post-tags-item post-tags-item-title">
Tags </a>
<a href="https://www.thepostmillennial.com/tag/censorship/" class="post-tags-item">
#censorship </a>
<a href="https://www.thepostmillennial.com/tag/journalist/" class="post-tags-item">
#journalist </a>
<a href="https://www.thepostmillennial.com/tag/social-media/" class="post-tags-item">
#Social Media </a>
<a href="https://www.thepostmillennial.com/tag/twitter/" class="post-tags-item">
#Twitter </a></div><div class="sh-clear"></div></div><div class="post-content-share-mobile-contaner"><div class="post-content-share post-content-share-bar post-content-share-mobile"></div></div><div id="tpm-related-posts-trigger"></div><div class="tpm-separator-title">Extended Readings(4)</div><div class="tpm-related-posts-contents"><div id="tpm-related-posts"><div class="tpm-single-post animated fadeIn lazy"><div class="post-featured-image"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="1600" height="800" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg" class="attachment-full size-full wp-post-image" alt="" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg 1600w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-300x150.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-768x384.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-1024x512.jpg 1024w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-585x293.jpg 585w" data-sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img width="1600" height="800" src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6.jpg 1600w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-300x150.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-768x384.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-1024x512.jpg 1024w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/3200b970-c1df-4630-82e3-3ecca316aff6-585x293.jpg 585w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript></div><h2 class="title"><a href="https://www.thepostmillennial.com/?post_type=post&p=119130">Twitter suspends NY Post writer after he exposes Carlos Maza’s riches and hypocrisy</a></h2><div class="subtitle"><div class="post-author"><a href="https://www.thepostmillennial.com/author/ianm/"><i class="fa fa-user-o" aria-hidden="true"></i> Ian Miles Cheong</a></div><div class="post-date"><i class="fa fa-clock-o" aria-hidden="true"></i> <span>2020-03-08 10:19:14</span></div></div><div class="post-content"><div class="content-html"><div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568834855780-0"></div></div><p>UPDATE: After Jonathan Levine was suspended from Twitter for posting a factual story about journalist Carlos Maza, he appealed the decision and was reinstated. In an email, a representative from Twitter claimed that the suspension was &#8220;in error.&#8221;<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">UPDATE:<br><br>Twitter locked me out of my account last night over some of the Carlos Maza reporting<br><br>A rep for the company tells me that their action against me was “an error” <br><br>TLDR — I’m out of Twitter jail and all my original postings here remain live!&mdash; Jon Levine (@LevineJonathan) <a href="https://twitter.com/LevineJonathan/status/1236668381417345024?ref_src=twsrc%5Etfw">March 8, 2020</a></blockquote></div></figure><p>Twitter has suspended Jonathan Levine, a reporter for the <em>New York Post</em>, following his publication of an article on former <em>Vox</em> video editor and leftist firebrand Carlos Maza, whose family fortune he laid bare.<div class='code-block code-block-15' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1578941510716-0" style="width: 1px; height: 1px;"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1578941510716-0'); });</script> </div></div><p>In the piece, titled <a href="https://nypost.com/2020/03/07/youtube-socialist-carlos-maza-slams-the-wealthy-but-lives-in-luxury/">“YouTube socialist Carlos Maza slams the wealthy but lived in luxury,”</a> Levine uncovered how the social media activist lives: in the lap of luxury while simultaneously condemning others for the sin of being wealthy.<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571169146169-0'></div><p>Maza attained infamy last year when he led a campaign to deplatform conservative pundit Steven Crowder from YouTube and other social media networks, and continues to call for the suspensions of his political adversaries on social media.<div class='code-block code-block-8' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055028523-0"></div></div><p>As Levine details, Maza often attacks political figures, including Democratic pundit James Carville, for living “in an absolutely obscene four-story mansion.” Referring to Carville as a “masterful con artist” and condemning him for warning other Democrats away from socialism, Maza reportedly wrote: “We should treat gay people the SAME WAY we treat straight people: Eating them when they get too rich.”<p>Maza, like other internet activists, garners the support of his fanbase through Patreon, where he serves content to over 700 patrons, earning him $2, $5, and $10 per supporter. Despite his ability to collect a monthly paycheck from his fans, Levine uncovered how the socialist firebrand is connected to “multiple Florida mega-mansions, a $7.1 million pad on the Upper West Side purchased under an LLC – and a yacht by luxury boat-maker Donzi.” This along with a detailed history of his family’s vast wealth, which includes millions of dollars in real estate—much of which Maza inherited, unlike James Carville.<p>Since reporting the story, Levine was banned for the post, in which he tweeted: “Here are some photos of the Florida home where Carlos Maza is registered to vote,” which includes photographs of the Maza family’s waterfront palace in Boca Raton, Florida.<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571169168367-0'></div><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055085416-0"></div></div><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Breaking: NY Post reporter <a href="https://twitter.com/LevineJonathan?ref_src=twsrc%5Etfw">@LevineJonathan</a> locked out of <a href="https://twitter.com/Twitter?ref_src=twsrc%5Etfw">@Twitter</a> after writing a story that outed socialist star Carlos Maza (<a href="https://twitter.com/gaywonk?ref_src=twsrc%5Etfw">@gaywonk</a>) as coming from elite wealth. The story has public real estate photos of Maza’s Florida waterfront palace. <a href="https://t.co/QuY9w8OIfG">https://t.co/QuY9w8OIfG</a>&mdash; Andy Ngo (@MrAndyNgo) <a href="https://twitter.com/MrAndyNgo/status/1236631270844551169?ref_src=twsrc%5Etfw">March 8, 2020</a></blockquote></div></figure><p>These were publicly available real estate photos.<figure class="wp-block-image"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17-748x1024.jpg" alt="" class="wp-image-119136" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17.jpg 748w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17-219x300.jpg 219w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17-585x801.jpg 585w" data-sizes="(max-width: 748px) 100vw, 748px" /><noscript><img src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17-748x1024.jpg" alt="" class="wp-image-119136" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17.jpg 748w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17-219x300.jpg 219w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/0f6eacda-8347-418a-af02-acc29fbe3c17-585x801.jpg 585w" sizes="(max-width: 748px) 100vw, 748px" /></noscript></figure><p>Curiously, Maza himself was never suspended for tweeting a similar set of posts about James Carville.<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Just found out James Carville &#8212; who spends his time lecturing Democrats for being &quot;too far left&quot; &#8212; lives in an absolutely obscene four story mansion and dear god can we STOP taking political advice from the ultra-wealthy. <a href="https://t.co/cSIA5dJbv6">pic.twitter.com/cSIA5dJbv6</a><div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571169374955-0'></div>&mdash; Carlos Maza 🌹 (@gaywonk) <a href="https://twitter.com/gaywonk/status/1227606222553133056?ref_src=twsrc%5Etfw">February 12, 2020</a></blockquote></div></figure><p>Another reporter and a former contributor of <em>The Young Turks</em>, Jordan Chariton, was suspended for “posting misleading information about voting” after he quoted Joe Biden for misspeaking.<div class='code-block code-block-10' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055134186-0"></div></div><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">NEWS: Twitter has “limited” <a href="https://twitter.com/JordanChariton?ref_src=twsrc%5Etfw">@JordanChariton</a>’s account—for reporting <a href="https://twitter.com/JoeBiden?ref_src=twsrc%5Etfw">@JoeBiden</a>’s OWN WORDS. Jordan can’t tweet for 12 hours&#8230; for the crime of journalism. <a href="https://twitter.com/TwitterSupport?ref_src=twsrc%5Etfw">@TwitterSupport</a> <a href="https://t.co/aKOcqQLov2">pic.twitter.com/aKOcqQLov2</a>&mdash; Jenn Dize 👩🏻‍💻 (@JennElizabethJ) <a href="https://twitter.com/JennElizabethJ/status/1234886686565437440?ref_src=twsrc%5Etfw">March 3, 2020</a></blockquote></div></figure><p>Twitter is now punishing journalists for reporting facts.<p>Sunday afternoon, Jonathan Levine posted that he&#8217;d heard back from Twitter.<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571169398558-0'></div><p><div class='code-block code-block-11' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1568235957261-0"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1568235957261-0'); });</script> </div></div><div class='code-block code-block-16' style='margin: 8px 0; clear: both;'><hr style=" border: 0; height: 1px; background: #333; background-image: linear-gradient(to right, #ccc, #333, #ccc);" /><div id="page-actions" style="line-height: 40px;"><h5>Want to help us grow? Here's what you can do!</h5><ol><li>
<a href="https://www.thepostmillennial.com/membership/" style="font-size:16px;">Become a member</a
></li><li>
<a href="https://www.facebook.com/ThePostMillennial/" style="font-size:16px;">Like our page on Facebook</a
></li><li>
<a href="https://twitter.com/TPostMillennial" style="font-size:16px;">Follow us on Twitter</a
></li></ol></div></div></div></div><div class="post-tags"><a class="post-tags-item post-tags-item-title">TAGS</a><a class="post-tags-item" href="/tag/journalist">#journalist</a><a class="post-tags-item" href="/tag/social-media">#Social Media</a><a class="post-tags-item" href="/tag/twitter">#Twitter</a></div><div class="tpm-separator"></div></div><div class="tpm-single-post animated fadeIn lazy"><div class="post-featured-image"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="474" height="266" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/th.jpg" class="attachment-full size-full wp-post-image" alt="" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/th.jpg 474w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/th-300x168.jpg 300w" data-sizes="(max-width: 474px) 100vw, 474px" /><noscript><img width="474" height="266" src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/th.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/th.jpg 474w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/th-300x168.jpg 300w" sizes="(max-width: 474px) 100vw, 474px" /></noscript></div><h2 class="title"><a href="https://www.thepostmillennial.com/?post_type=post&p=119124">No matter what you think of Woody Allen, censorship is wrong</a></h2><div class="subtitle"><div class="post-author"><a href="https://www.thepostmillennial.com/author/collin-jones/"><i class="fa fa-user-o" aria-hidden="true"></i> Collin Jones</a></div><div class="post-date"><i class="fa fa-clock-o" aria-hidden="true"></i> <span>2020-03-08 10:00:45</span></div></div><div class="post-content"><div class="content-html"><div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568834855780-0"></div></div><p>Woody Allen’s memoir <em>Apropos of Nothing</em> has now been cancelled after a <a href="https://www.vox.com/culture/2020/3/6/21168332/woody-allen-hachette-publisher-memoir-canceled-staff-walk-out">staff walkout</a> at Hachette Book Group, an imprint of Little, Brown and Company. The walkout was ignited by Allen’s adopted daughter Dylan Farrow’s accusation that he had molested her when she was seven years old. Allen denies the charge. This book is just one among a number that have been cancelled in recent years. <em>American Dirt </em>by Jeanine Cummins’s book tour was cancelled due to “<a href="https://www.cnn.com/2020/01/29/us/american-dirt-jeanine-cummins-author-tour-cancel-trnd/index.html">safety concerns</a>.” And the YA book entitled <em>Blood Heir </em>was pulled by the author, Amélie Wen Zhao, after she was accused of displaying “<a href="https://www.nytimes.com/2019/01/31/books/amelie-wen-zhao-blood-heir-ya-author-pulls-debut-accusations-racism.html">blatantly racist</a>” depictions of slavery.<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Feminists celebrating book pulping caused by staff walkout aren&#39;t doing themselves any favours for future. It&#39;s v bad precedent. (There&#39;s also no court conviction. Redemption narratives by *convicted* criminals get published all the time). This isn&#39;t wise, just, or brave decision&mdash; Kathleen Stock (@Docstockk) <a href="https://twitter.com/Docstockk/status/1236243666966065153?ref_src=twsrc%5Etfw">March 7, 2020</a></blockquote></div></figure><p>When there are hoorays and cheers for books being cancelled—books that authors have worked hard on for years—it makes me wonder if it is even worth it to create at all. Being an MFA graduate student in Minnesota, I intend to use part of my professional career writing novels and short stories. The grad program was supposed to be a mechanism to sharpen the writing skills I had developed in the few years since my undergrad, but in my first semester in the graduate program, I have already been labelled an ableist and accused of holding the ideas I do simply because I’m “a f***ing a white guy.”<div class='code-block code-block-15' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1578941510716-0" style="width: 1px; height: 1px;"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1578941510716-0'); });</script> </div></div><p>These accusations have been based on my fiction writing as well as my views on what fiction should do and what it should be. The professor in whose class I was called these names did not step in to say that it was unprofessional or inappropriate to launch such personal attacks, but instead smiled, as if she agreed wholeheartedly. It is clear that there is a concerted effort to censor ideas with which faculty and students don’t want to engage.<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571169414266-0'></div><p>Allen’s memoir was not cancelled for anything inside the book itself. <a href="https://www.nationalreview.com/corner/woody-allen-gets-canceled-again/">It was cancelled because of what he had allegedly done in his personal life</a>. In fact, those accusations have not produced anything of substance. If someone had enough information to charge Allen with molestation or sexual assault, then they should try him on that account (and I would be right there with them), but to cancel his book is an overt attempt to shut someone out of the marketplace of ideas, to smear reputation and work, based on nothing but collective hatred for the guy.<div class='code-block code-block-8' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055028523-0"></div></div><p>As something of a free speech absolutist (with very few exceptions), I believe that ideas should be exchanged and debated until one idea prevails over the other. If, say, someone disagrees with the content of Marquis De Sade’s <em>120 Days of Sodom</em>, then they should be able to write or speak about what they dislike. To ban the book entirely negates all conversation that could have taken place.<p>If you don’t want to read a given book because of its content, then that is your prerogative, but there is no reason to make it unavailable for others who might have an interest. This quickly turns into a kind of moralizing, where the gatekeepers get to decide what is best for me to read, watch, and listen to. That the gatekeepers are now vilifying authors not for the taboo content of their work but for perceived personal misdeeds makes no difference.<p>The censorship of Allen’s book is a perfect example of how group think has now gained prominent influence over the gatekeepers. If enough people vandalize colleges over invited speakers, then those colleges are going to avoid controversial voices from speaking on their campus. The same goes for book publishers, where they will cancel books based on a group of people expressing their discontent with the book being published.<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571170239758-0'></div><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055085416-0"></div></div><p>Why is it not okay to just not like a book? Why do books have to be cancelled before people can be satisfied? There are many, many books published every year that I think are absolutely atrocious, but I would never think to bar that author from publishing their book. It’s their right to say what they want to say, and it is my right to say their ideas are stupid—but I do not have the right to silence them.&nbsp;<div class='code-block code-block-11' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1568235957261-0"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1568235957261-0'); });</script> </div></div><div class='code-block code-block-16' style='margin: 8px 0; clear: both;'><hr style=" border: 0; height: 1px; background: #333; background-image: linear-gradient(to right, #ccc, #333, #ccc);" /><div id="page-actions" style="line-height: 40px;"><h5>Want to help us grow? Here's what you can do!</h5><ol><li>
<a href="https://www.thepostmillennial.com/membership/" style="font-size:16px;">Become a member</a
></li><li>
<a href="https://www.facebook.com/ThePostMillennial/" style="font-size:16px;">Like our page on Facebook</a
></li><li>
<a href="https://twitter.com/TPostMillennial" style="font-size:16px;">Follow us on Twitter</a
></li></ol></div></div></div></div><div class="post-tags"><a class="post-tags-item post-tags-item-title">TAGS</a><a class="post-tags-item" href="/tag/censorship">#censorship</a><a class="post-tags-item" href="/tag/college">#college</a></div><div class="tpm-separator"></div></div><div class="tpm-single-post animated fadeIn lazy"><div class="post-featured-image"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="1324" height="689" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS.jpg" class="attachment-full size-full wp-post-image" alt="" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS.jpg 1324w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-300x156.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-768x400.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-1024x533.jpg 1024w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-585x304.jpg 585w" data-sizes="(max-width: 1324px) 100vw, 1324px" /><noscript><img width="1324" height="689" src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS.jpg 1324w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-300x156.jpg 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-768x400.jpg 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-1024x533.jpg 1024w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/Image-from-iOS-585x304.jpg 585w" sizes="(max-width: 1324px) 100vw, 1324px" /></noscript></div><h2 class="title"><a href="https://www.thepostmillennial.com/?post_type=post&p=118870">WATCH: MSNBC and NYT journalists fail at basic math</a></h2><div class="subtitle"><div class="post-author"><a href="https://www.thepostmillennial.com/author/libbyemmons/"><i class="fa fa-user-o" aria-hidden="true"></i> Libby Emmons</a></div><div class="post-date"><i class="fa fa-clock-o" aria-hidden="true"></i> <span>2020-03-06 07:29:45</span></div></div><div class="post-content"><div class="content-html"><div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568834855780-0"></div></div><p>MSNBC&#8217;s Brian Williams went on air with New York Times Editorial Board Member Mara Gay and dedicated an entire news segment to a tweet from writer Mekita Rivas.<p>&#8220;Bloomberg spent $500 million on ads,&#8221; Rivas&#8217; tweet says. &#8220;The U.S. population is 327 million. He could have given each American $1 million and still have money left over. I feel like a $1 million check would be life-changing for most people. Yet he wasted it all on ads and STILL LOST.&#8221;<div class='code-block code-block-15' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1578941510716-0" style="width: 1px; height: 1px;"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1578941510716-0'); });</script> </div></div><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">how did this end up on tv? <a href="https://t.co/xUYIOChhKv">pic.twitter.com/xUYIOChhKv</a>&mdash; andrew kaczynski🤔 (@KFILE) <a href="https://twitter.com/KFILE/status/1235808311834021888?ref_src=twsrc%5Etfw">March 6, 2020</a></blockquote></div></figure><p>If Bloomberg took $500 million and divided it among 327 million Americans, that would be $1.53 per person. $500 million would only give $1 million to 500 people.<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571170259078-0'></div><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">I&#39;m speechless.<br><br>I thought they were going to mock the stupidity of the tweet, but then she says it&#39;s true and I can&#39;t believe it&#39;s real.<br> <a href="https://t.co/F47R7hrp2N">pic.twitter.com/F47R7hrp2N</a>&mdash; Josh Jordan (@NumbersMuncher) <a href="https://twitter.com/NumbersMuncher/status/1235812262423588865?ref_src=twsrc%5Etfw">March 6, 2020</a></blockquote></div></figure><p>Neither Williams nor Gay noticed this bad math on live television. Nor did the producer who gave them the tweet to discuss on air. No one in the studio that fed this erroneous tweet to the pundits realized that Rivas&#8217; math was 100 percent bogus.<div class='code-block code-block-8' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055028523-0"></div></div><p>Rivas has since locked her Twitter account and protected her tweets, but updated her bio to say &#8220;I know, I’m bad at math.&#8221;<p>Rivas blamed Bloomberg for not being able to buy the American presidential election with his $500 million. But that is not a failing of the former New York City mayor, but a credit to the American people.<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571170275490-0'></div><p>Mekita Rivas, Brian Williams, and Mara Gay have all been verified by Twitter, a blue check mark added to their names. As <a href="https://www.thepostmillennial.com/twitter-is-not-to-be-trusted-when-it-comes-to-misinformation/">Twitter rolls out its new plans to protect the public against fake news</a>, it intends to enable verified accounts to discern the difference from truth and fiction.<div class='code-block code-block-9' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055085416-0"></div></div><div class='code-block code-block-11' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1568235957261-0"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1568235957261-0'); });</script> </div></div><div class='code-block code-block-16' style='margin: 8px 0; clear: both;'><hr style=" border: 0; height: 1px; background: #333; background-image: linear-gradient(to right, #ccc, #333, #ccc);" /><div id="page-actions" style="line-height: 40px;"><h5>Want to help us grow? Here's what you can do!</h5><ol><li>
<a href="https://www.thepostmillennial.com/membership/" style="font-size:16px;">Become a member</a
></li><li>
<a href="https://www.facebook.com/ThePostMillennial/" style="font-size:16px;">Like our page on Facebook</a
></li><li>
<a href="https://twitter.com/TPostMillennial" style="font-size:16px;">Follow us on Twitter</a
></li></ol></div></div></div></div><div class="post-tags"><a class="post-tags-item post-tags-item-title">TAGS</a><a class="post-tags-item" href="/tag/msnbc">#MSNBC</a><a class="post-tags-item" href="/tag/new-york-times">#New York Times</a><a class="post-tags-item" href="/tag/social-media">#Social Media</a><a class="post-tags-item" href="/tag/twitter">#Twitter</a></div><div class="tpm-separator"></div></div><div class="tpm-single-post animated fadeIn lazy"><div class="post-featured-image"><img data-lazyloaded="1" src="data:image/gif;base64,R0lGODdhAQABAPAAAMPDwwAAACwAAAAAAQABAAACAkQBADs=" width="1600" height="800" data-src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok.png" class="attachment-full size-full wp-post-image" alt="" data-srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok.png 1600w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-300x150.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-768x384.png 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-1024x512.png 1024w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-585x293.png 585w" data-sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img width="1600" height="800" src="https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok.png" class="attachment-full size-full wp-post-image" alt="" srcset="https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok.png 1600w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-300x150.png 300w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-768x384.png 768w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-1024x512.png 1024w, https://www.thepostmillennial.com/wp-content/uploads/2020/03/twitterok-585x293.png 585w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript></div><h2 class="title"><a href="https://www.thepostmillennial.com/?post_type=post&p=118857">Twitter’s new rules: ‘OK Boomer’ not OK but Trump-bashing may continue</a></h2><div class="subtitle"><div class="post-author"><a href="https://www.thepostmillennial.com/author/ianm/"><i class="fa fa-user-o" aria-hidden="true"></i> Ian Miles Cheong</a></div><div class="post-date"><i class="fa fa-clock-o" aria-hidden="true"></i> <span>2020-03-05 21:40:26</span></div></div><div class="post-content"><div class="content-html"><div class='code-block code-block-7' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568834855780-0"></div></div><p>Twitter is expanding upon its never-ceasing, ever-worsening terms of service that do nothing to protect its users from actual harm, by adding several new clauses to its hateful conduct rules.<p>In addition to the already present anti-misgendering rules that ban users for accidentally referring to Jessica Yaniv as a “he,” the social media platform is now going to include “<a href="https://blog.twitter.com/en_us/topics/company/2019/hatefulconductupdate.html">language that dehumanizes on the basis of age, disability or disease</a>.”<div class='code-block code-block-15' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1578941510716-0" style="width: 1px; height: 1px;"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1578941510716-0'); });</script> </div></div><p>This means that the remark, “OK boomer,” may result in a swift suspension, as will jokes about former Vice President and current Democratic presidential forerunner Joe Biden, who may or may not be showing signs of early onset dementia.&nbsp;<p>While the rules can be broadly misinterpreted depending on who’s doing the reporting (see: Yaniv), some blue checkmarks on Twitter have expressed approval of the new policy. Writing on Twitter, NBC reporter Ben Collins implied that the only people upset by the changes are going to be gamers.&nbsp;<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571170289487-0'></div><div class='code-block code-block-8' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055028523-0"></div></div><p>“A lot of people whose entire identities are tied to being disproportionately mean on Twitter to anyone who makes them feel deeply insecure while eating Doritos at 3 in the morning are furious at this,” he wrote.&nbsp;<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">While I do think this rule could be applied too broadly in the wrong hands, a lot of people whose entire identities are tied to being disproportionately mean on Twitter to anyone who makes them feel deeply insecure while eating Doritos at 3 in the morning are furious at this.&mdash; Ben Collins (@oneunderscore__) <a href="https://twitter.com/oneunderscore__/status/1235735708444352512?ref_src=twsrc%5Etfw">March 6, 2020</a></blockquote></div></figure><p>The new policy also raises questions as to whether anyone who responds to jokes by disabled comedians like legally blind <a href="https://twitter.com/jordylancaster/status/1235403254315565056">Johnny Walsh</a>, and <a href="https://twitter.com/rickyberwick">Ricky Berwick</a> and Donovan Castillo (aka <a href="https://twitter.com/RealYungCripp">RealYungCripp</a>), could be banned if reported for making jokes that could be interpreted as dehumanizing.<p>According to Twitter, the company is instituting its new policy because “research shows that dehumanizing language increases [the risks of offline harm].” The company provided examples of tweets that could get users suspended, including:<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571170302619-0'></div><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055085416-0"></div></div><p>“All [Age Group] are leeches and don’t deserve any support from us.”<p>“People with [Disease] are rats that contaminate everyone around them.”<p>“People with [Disability] are subhuman and shouldn’t be seen in public.”<div class='code-block code-block-10' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568055134186-0"></div></div><p>“[Religious Group] should be punished. We are not doing enough to get rid of those filthy animals.”<div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571170315207-0'></div><p>The company says that based on feedback, it is going to narrow down what is considered an “identifiable group,” as users complained that they should be “allowed to engage with political groups, hate groups, and other non-marginalized groups with this type of language.” According to the company, many people wanted to “call out hate groups in any way, any time, without fear.”&nbsp;<p>Twitter says it plans to protect those who have conversations within marginalized groups, including people who use “reclaimed terminology,” and that it plans to account for “power dynamics that come into play across different groups.”&nbsp;<p>In other words, don’t expect anyone to be banned for calling for the eradication of white Trump-supporting conservatives, but do expect to be suspended for speaking out against illegal immigration. <div class='code-block code-block-11' style='margin: 8px 0; clear: both;'><div id="div-gpt-ad-1568235957261-0"> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1568235957261-0'); });</script> </div></div><div class='code-block code-block-16' style='margin: 8px 0; clear: both;'><hr style=" border: 0; height: 1px; background: #333; background-image: linear-gradient(to right, #ccc, #333, #ccc);" /><div id="page-actions" style="line-height: 40px;"><h5>Want to help us grow? Here's what you can do!</h5><ol><li>
<a href="https://www.thepostmillennial.com/membership/" style="font-size:16px;">Become a member</a
></li><li>
<a href="https://www.facebook.com/ThePostMillennial/" style="font-size:16px;">Like our page on Facebook</a
></li><li>
<a href="https://twitter.com/TPostMillennial" style="font-size:16px;">Follow us on Twitter</a
></li></ol></div></div><div class='gam_ads repeating_ads animated fadeIn' id='div-gpt-ad-1571169146169-0'></div></div></div><div class="post-tags"><a class="post-tags-item post-tags-item-title">TAGS</a><a class="post-tags-item" href="/tag/censorship">#censorship</a><a class="post-tags-item" href="/tag/political-correctness">#political correctness</a><a class="post-tags-item" href="/tag/twitter">#Twitter</a></div><div class="tpm-separator"></div></div></div></div></div><div class="post-related-title post-slide-arrows-container"><h2 class="post-single-title">
Related posts</h2></div><div class="post-related"><div class="post-related-item"><article id="post-61788" class="post-item post-61788 post type-post status-publish format-standard has-post-thumbnail hentry category-canada-news category-news"><div class="post-container"><div class="post-thumbnail"><div class="sh-ratio"><div class="sh-ratio-container"><div class="sh-ratio-content" style="background-image: url( https://www.thepostmillennial.com/wp-content/uploads/2019/01/1-68.jpg);"></div></div></div>
<a href="https://www.thepostmillennial.com/saudi-accused-of-sexual-assault-disappears-from-canada-after-embassy-posts-bail/" class="post-overlay"></a><div class="post-categories-container"><div class="post-categories"><a href="https://www.thepostmillennial.com/category/news/canada-news/">Canadian News</a></div></div></div><div class="post-content-container">
<a href="https://www.thepostmillennial.com/saudi-accused-of-sexual-assault-disappears-from-canada-after-embassy-posts-bail/" class="post-title"><h4> Saudi accused of sexual assault disappears from Canada after embassy posts bail&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="61788"><i class="fa fa-bookmark-o"></i></span></h4> </a><div class="post-meta"><div class="post-meta-content">
<span class="post-auhor-date">
<span>
<a href="https://www.thepostmillennial.com/author/alitaghva/" class="post-author">Ali Taghva</a></span>,
<a href="https://www.thepostmillennial.com/saudi-accused-of-sexual-assault-disappears-from-canada-after-embassy-posts-bail/" class="post-date">
1 year ago </a>
</span>
<span class="post-readtime">
<i class="icon icon-clock"></i>
2 min <span>read</span> </span>
<span class="desktop-post-read-later">
&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="61788"><i class="fa fa-bookmark-o"></i></span> </span></div></div></div></div></article></div><div class="post-related-item"><article id="post-109864" class="post-item post-109864 post type-post status-publish format-standard has-post-thumbnail hentry category-canada-news category-international-news category-news category-ontario tag-iran tag-terrorism"><div class="post-container"><div class="post-thumbnail"><div class="sh-ratio"><div class="sh-ratio-container"><div class="sh-ratio-content" style="background-image: url( https://www.thepostmillennial.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-04-at-8.08.18-PM-420x265.png);"></div></div></div>
<a href="https://www.thepostmillennial.com/watch-iranian-canadian-rips-trudeaus-weakness-on-terrorism/" class="post-overlay"></a><div class="post-categories-container"><div class="post-categories"><a href="https://www.thepostmillennial.com/category/news/canada-news/">Canadian News</a></div></div></div><div class="post-content-container">
<a href="https://www.thepostmillennial.com/watch-iranian-canadian-rips-trudeaus-weakness-on-terrorism/" class="post-title"><h4> WATCH: Iranian-Canadian rips Trudeau’s weakness on terrorism&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="109864"><i class="fa fa-bookmark-o"></i></span></h4> </a><div class="post-meta"><div class="post-meta-content">
<span class="post-auhor-date">
<span>
<a href="https://www.thepostmillennial.com/author/bethbaischbw/" class="post-author">Beth Baisch and Barrett Wilson</a></span>,
<a href="https://www.thepostmillennial.com/watch-iranian-canadian-rips-trudeaus-weakness-on-terrorism/" class="post-date">
2 months ago </a>
</span>
<span class="post-readtime">
<i class="icon icon-clock"></i>
1 min <span>read</span> </span>
<span class="desktop-post-read-later">
&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="109864"><i class="fa fa-bookmark-o"></i></span> </span></div></div></div></div></article></div><div class="post-related-item"><article id="post-101163" class="post-item post-101163 post type-post status-publish format-standard has-post-thumbnail hentry category-business_finance category-canada-news tag-justin-trudeau tag-liberals tag-trans-mountain-pipeline"><div class="post-container"><div class="post-thumbnail"><div class="sh-ratio"><div class="sh-ratio-container"><div class="sh-ratio-content" style="background-image: url( https://www.thepostmillennial.com/wp-content/uploads/2019/02/jpg1-10-420x265.jpg);"></div></div></div>
<a href="https://www.thepostmillennial.com/trudeau-liberals-to-comply-with-trans-mountain-pipeline-demands/" class="post-overlay"></a><div class="post-categories-container"><div class="post-categories"><a href="https://www.thepostmillennial.com/category/business_finance/">Business &amp; Finance</a></div></div></div><div class="post-content-container">
<a href="https://www.thepostmillennial.com/trudeau-liberals-to-comply-with-trans-mountain-pipeline-demands/" class="post-title"><h4> Trudeau Liberals to comply with Trans Mountain pipeline demands&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="101163"><i class="fa fa-bookmark-o"></i></span></h4> </a><div class="post-meta"><div class="post-meta-content">
<span class="post-auhor-date">
<span>
<a href="https://www.thepostmillennial.com/author/dylangibbons/" class="post-author">Dylan Gibbons</a></span>,
<a href="https://www.thepostmillennial.com/trudeau-liberals-to-comply-with-trans-mountain-pipeline-demands/" class="post-date">
5 months ago </a>
</span>
<span class="post-readtime">
<i class="icon icon-clock"></i>
3 min <span>read</span> </span>
<span class="desktop-post-read-later">
&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="101163"><i class="fa fa-bookmark-o"></i></span> </span></div></div></div></div></article></div><div class="post-related-item"><article id="post-77461" class="post-item post-77461 post type-post status-publish format-standard has-post-thumbnail hentry category-canada-news category-news"><div class="post-container"><div class="post-thumbnail"><div class="sh-ratio"><div class="sh-ratio-container"><div class="sh-ratio-content" style="background-image: url( https://www.thepostmillennial.com/wp-content/uploads/2019/05/1-114.jpg);"></div></div></div>
<a href="https://www.thepostmillennial.com/edmonton-woman-in-distress-seen-dancing-without-pants-on-money-mart-roof-top/" class="post-overlay"></a><div class="post-categories-container"><div class="post-categories"><a href="https://www.thepostmillennial.com/category/news/canada-news/">Canadian News</a></div></div></div><div class="post-content-container">
<a href="https://www.thepostmillennial.com/edmonton-woman-in-distress-seen-dancing-without-pants-on-money-mart-roof-top/" class="post-title"><h4> Edmonton woman in distress seen dancing without pants on Money Mart roof-top&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="77461"><i class="fa fa-bookmark-o"></i></span></h4> </a><div class="post-meta"><div class="post-meta-content">
<span class="post-auhor-date">
<span>
<a href="https://www.thepostmillennial.com/author/travis-gladue/" class="post-author">Travis Gladue-Beauregard</a></span>,
<a href="https://www.thepostmillennial.com/edmonton-woman-in-distress-seen-dancing-without-pants-on-money-mart-roof-top/" class="post-date">
10 months ago </a>
</span>
<span class="post-readtime">
<i class="icon icon-clock"></i>
1 min <span>read</span> </span>
<span class="desktop-post-read-later">
&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="77461"><i class="fa fa-bookmark-o"></i></span> </span></div></div></div></div></article></div><div class="post-related-item"><article id="post-82101" class="post-item post-82101 post type-post status-publish format-standard has-post-thumbnail hentry category-business_finance category-politics_policy category-quebec"><div class="post-container"><div class="post-thumbnail"><div class="sh-ratio"><div class="sh-ratio-container"><div class="sh-ratio-content" style="background-image: url( https://www.thepostmillennial.com/wp-content/uploads/2019/07/Francois-Legault-750x375-420x265.jpg);"></div></div></div>
<a href="https://www.thepostmillennial.com/quebec-government-pledges-70m-to-give-immigrants-easier-access-to-french-lessons/" class="post-overlay"></a><div class="post-categories-container"><div class="post-categories"><a href="https://www.thepostmillennial.com/category/business_finance/">Business &amp; Finance</a></div></div></div><div class="post-content-container">
<a href="https://www.thepostmillennial.com/quebec-government-pledges-70m-to-give-immigrants-easier-access-to-french-lessons/" class="post-title"><h4> Quebec government pledges $70M to give immigrants easier access to French lessons&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="82101"><i class="fa fa-bookmark-o"></i></span></h4> </a><div class="post-meta"><div class="post-meta-content">
<span class="post-auhor-date">
<span>
<a href="https://www.thepostmillennial.com/author/roberto/" class="post-author">Roberto Wakerell-Cruz</a></span>,
<a href="https://www.thepostmillennial.com/quebec-government-pledges-70m-to-give-immigrants-easier-access-to-french-lessons/" class="post-date">
8 months ago </a>
</span>
<span class="post-readtime">
<i class="icon icon-clock"></i>
2 min <span>read</span> </span>
<span class="desktop-post-read-later">
&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="82101"><i class="fa fa-bookmark-o"></i></span> </span></div></div></div></div></article></div><div class="post-related-item"><article id="post-106364" class="post-item post-106364 post type-post status-publish format-standard has-post-thumbnail hentry category-british-columbia category-canada-news category-crime tag-british-columbia tag-crime"><div class="post-container"><div class="post-thumbnail"><div class="sh-ratio"><div class="sh-ratio-container"><div class="sh-ratio-content" style="background-image: url( https://www.thepostmillennial.com/wp-content/uploads/2019/12/strimbold-420x265.jpg);"></div></div></div>
<a href="https://www.thepostmillennial.com/former-mayor-of-burns-lake-jail-bound/" class="post-overlay"></a><div class="post-categories-container"><div class="post-categories"><a href="https://www.thepostmillennial.com/category/news/canada-news/british-columbia/">British Columbia</a></div></div></div><div class="post-content-container">
<a href="https://www.thepostmillennial.com/former-mayor-of-burns-lake-jail-bound/" class="post-title"><h4> Former B.C. mayor heading to jail for sexual assault&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="106364"><i class="fa fa-bookmark-o"></i></span></h4> </a><div class="post-meta"><div class="post-meta-content">
<span class="post-auhor-date">
<span>
<a href="https://www.thepostmillennial.com/author/quinn/" class="post-author">Quinn Patrick</a></span>,
<a href="https://www.thepostmillennial.com/former-mayor-of-burns-lake-jail-bound/" class="post-date">
3 months ago </a>
</span>
<span class="post-readtime">
<i class="icon icon-clock"></i>
3 min <span>read</span> </span>
<span class="desktop-post-read-later">
&nbsp;<span class="post-read-later post-read-later-guest" href="#login-register" data-type="add" data-id="106364"><i class="fa fa-bookmark-o"></i></span> </span></div></div></div></div></article></div></div><div class="post-related-arrows"><div class="post-slide-arrows sh-carousel-buttons-styling"></div></div></article></div></div><div id="sidebar" class="sidebar-right"><div class="sidebar-container"><div id="social_v2-3" class="widget_social_v2 widget-item widget_social_v2"><div class="sh-widget-title-styling"><h3 class="widget-title">Social Media</h3></div><div class="sh-widget-socialv2-list"><a href="https://twitter.com/TPostMillennial" target="_blank" class="sh-widget-socialv2-item social-media-twitter">
<i class="fa fa-twitter"></i>
</a><a href="https://www.facebook.com/ThePostMillennial/" target="_blank" class="sh-widget-socialv2-item social-media-facebook">
<i class="fa fa-facebook"></i>
</a><a href="https://www.instagram.com/thepostmillennial/" target="_blank" class="sh-widget-socialv2-item social-media-instagram">
<i class="fa fa-instagram"></i>
</a><a href="https://www.linkedin.com/company/18260476" target="_blank" class="sh-widget-socialv2-item social-media-wordpress">
<i class="fa fa-linkedin"></i>
</a><a href="https://www.youtube.com/channel/UCOzojJATlDfb6LdXCXN79zg" target="_blank" class="sh-widget-socialv2-item social-media-wordpress">
<i class="fa fa-youtube"></i>
</a><div class="sh-clear"></div></div></div><div id="ai_widget-3" class="widget-item ai_widget"><div class='code-block code-block-6' style='margin: 8px 0; clear: both;'><div class="gam_ads" id="div-gpt-ad-1568054931607-0"></div></div></div><div id="custom_html-3" class="widget_text widget-item widget_custom_html"><div class="textwidget custom-html-widget"><div class="sidebar-footer">
<a href="https://www.thepostmillennial.com/ethical-journalism-policy-and-mission-statement/">Ethical Journalism
Policy And Mission Statement
</a></div><div class="sidebar-footer">
<a href="https://www.thepostmillennial.com/privacy/">Privacy Policy</a></div><div class="sidebar-footer">
<a href="https://www.thepostmillennial.com/about-us/">About Us </a></div><div class="sidebar-footer">
<a href="https://www.thepostmillennial.com/contact-us/">Contact Us </a></div></div></div></div></div></div></div></div><footer class="sh-footer"><div class="sh-copyrights sh-copyrights-align-center"><div class="container container-padding"><div class="sh-table"><div class="sh-table-cell"><div class="sh-copyrights-info">
<span>©Copyright 2019 The Post Millennial</span></div></div><div class="sh-table-cell"></div></div></div></div></footer></div><div class="sh-back-to-top sh-back-to-top1">
<i class="fa fa-angle-up"></i></div><div id="login-register" style="display: none;"><div class="sh-login-popup-tabs"><ul class="nav nav-tabs"><li class="active">
<a data-target="#viens" data-toggle="tab">Login</a></li><li>
<a data-target="#divi" data-toggle="tab">Register</a></li></ul></div><div class="tab-content"><div class="tab-pane active" id="viens"><div class="sh-login-popup-content sh-login-popup-content-login"><form name="loginform" id="loginform" action="https://www.thepostmillennial.com/9ra7n6hc08q672zu/" method="post"><p class="login-username">
<label for="user_login">Username or Email Address</label>
<input type="text" name="log" id="user_login" class="input" value="" size="20" /></p><p class="login-password">
<label for="user_pass">Password</label>
<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" /></p><p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" /> Remember Me</label></p><p class="login-submit">
<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Log In" />
<input type="hidden" name="redirect_to" value="https://www.thepostmillennial.com/breaking-twitter-re-suspends-ny-post-writer-for-tweets-about-activist-journalist-carlos-maza/" /></p></form></div></div><div class="tab-pane" id="divi"><div class="sh-login-popup-content"><p id="reg_passmail">Please click on the following link for registration: <br><br><a href="/membership">Join Us ($1 for first one month)</a></p></div></div></div></div></div> <script type='text/javascript'>/*  */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/www.thepostmillennial.com\/","top_ten_id":"119160","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"151383559"};
/*  */</script> <script type='text/javascript'>/*  */
var pollsL10n = {"ajax_url":"https:\/\/www.thepostmillennial.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/*  */</script> <script type="text/javascript">jQuery(document).ready(function ($) { "use strict"; });</script> <script data-optimized='1' src='https://www.thepostmillennial.com/min/2c568.js'></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></body></html>

